Создание VPN туннелей

VPN туннели для Mikrotik

(запись не завершена, но уже полезна)

Введение

а

Удаленный доступ в сеть

а

Связка L2TP + IPSec

Протокол L2TP обеспечивает туннель канал передачи данных, а
IPSec обеспечивает шифрование.

Сервер VPN
Пакет PPP

Необходимые для настройки VPN средства включены в состав пакета PPP, который должен быть разрешен для того, чтобы раздел PPP присутствовал в меню.

Если раздел меню PPP отсутствует, то разрешение пакета выполняется в WinBox:IP->System->Packages.

После разрешения пакета RouterOS необходимо перезагрузить.

/system package enable ppp; /system reboot; 
Reboot, yes? [y/N]:
Пул адресов

Специальный пул адресов для vpn подключений

Учетные записи для vpn подключений

WinBox:IP->PPP->Secrets.

Доступ через Firewall

Для L2TP необходимо открыть стандартный порт UDP:1701, а для IPsec ISAKMP establishing PHASE 1 UDP:500 и IPsec NAT traversal UDP:4500

/ip firewall filter
add chain=input action=accept protocol=udp port=1701,500,4500
add chain=input action=accept protocol=ipsec-esp

 

Клиент VPN
Сетевое VPN подключение

Для соединения подходит стандартный Windows VPN клиент начиная с Windows 7.

В свойствах подключения следует указать Тип VPN.

… и в [Дополнительные параметры] внести Ключ установленный в Winbox->PPP->Interface->L2TP Server->IPSec Secret  и Winbox->IP->IPSec->Peers->0.0.0.0/0->Secret

Маршрут

Установленное подключение VPN перенаправляет через себя весь сетевой трафик. Если этого не требуется, то следует создать маршрут на основе приведенного шаблона:

route add 192.168.2.0 mask 255.255.255.0 192.168.2.2  -p

Дополнения

L2TP

L2TP (англ. Layer 2 Tunneling Protocol — протокол туннелирования второго уровня) — в компьютерных сетях туннельный протокол, использующийся для поддержки виртуальных частных сетей. Главное достоинство L2TP состоит в том, что этот протокол позволяет создавать туннель не только в сетях IP, но и в таких, как ATM, X.25 и Frame Relay.

Несмотря на то, что L2TP действует наподобие протокола Канального уровня модели OSI, на самом деле он является протоколом Сеансового уровня и использует зарегистрированный UDP-порт 1701.

Источники

  • Настройка VPN IPSec/L2TP сервера Mikrotik bozza.ru
  • Настройка PPP интерфейсов и серверов в Mikrotik asp24.com.ua
  • История «болезней» VPN osp.ru
  • Сравнительный обзор реализаций технологии VPN: что выбрать? на 1cloud.ru
  • Настройка OpenVPN-сервера на Windows Server 2008/2012 на 1cloud.ru
  • Пошаговая инструкция по объединению сетей с помощью L2TP и L2TP/IPSec на Mikrotik lanmarket.ua

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *