Настройка Mikrotik для нескольких ISP

Маршрутизатор Mikrotik способен гибко управлять трафиком произвольного числа внешних ISP подключений к произвольному числу внутренних серверов и сервисов. Задача эта является непростой и может быть решена несколькими способами.

Способ 1. Основной + резервный.

Вариант A

Способ реализует простейшую отказоустойчивость для исходящего трафика через одного из двух ISP. Отказ основного детектируется по ARP, после этого маршрутизация переключается на второго ISP.

Значение distance для каждого isp-подключения  определяет его приоритет и порядок переключает исходящий трафик с основного isp-подключения на резервный.

/ip route

add check-gateway=arp dst-address=0.0.0.0/0 gateway=80.80.80.1 routing-mark=r1 distance=1

add check-gateway=arp dst-address=0.0.0.0/0 gateway=90.90.90.1 routing-mark=r2 distance=2
Вариант B.

Способ аналогичен предыдущему варианту, но детектирование функционирования ISP выполняется посредством PING к хосту в глобальной сети с предопределенным маршрутом.

!!!продолжение следует.

Способ 2. Пропорциональное распределение.

Простейшее равномерное распределение исходящих соединений между двумя isp-подключениями:

/ip firewall mangle

add act=mark-connection ch=prerouting connection-state=new new-connection-mark=c1 nth=2,1 passthrough=yes

add act=mark-connection ch=prerouting connection-state=new new-connection-mark=c2 nth=2,2 passthrough=yes

add act=mark-routing ch=prerouting connection-mark=c1 new-routing-mark=r1 passthrough=yes

add act=mark-routing ch=prerouting connection-mark=c2 new-routing-mark=r2 passthrough=yes

/ip route

add check-gateway=arp dst-address=0.0.0.0/0 gateway=80.80.80.1 routing-mark=r1 scope=255

add check-gateway=arp dst-address=0.0.0.0/0 gateway=90.90.90.1 routing-mark=r2 scope=255

add disabled=no dst-address=0.0.0.0/0 gateway=80.80.80.1 scope=255

Способ X

Способ с использованием списков (применим для RouterOS от версии 6.36).

Источники

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *